Update Python 2.7.5 on CentOS7

Update Python 2.7.5 on CentOS7

Hi! Due to CVE-2021-3177, I am required to update/patch Python on my system. Currently running python-2.7.5-90.el7. Security scans are failing me due to having that version of python which is prone to the CVE.

I'm aware replacing python 2.7.5 will break my system but im not sure how I can maybe get a newer version of python in its place. Running "yum update python" says all packages updated. Is there a certain repo I should be pulling from? How do I hotfix my python but not break CentOS?

submitted by /u/Silence_of_the_LAN
[link] [comments]

* This article was originally published here

Leave a Reply

Your email address will not be published. Required fields are marked *